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Installation of Metrics I/CV 3.9 

 

Introduction 

 

The Metrics I/CV version 3.9 software product has undergone a significant change in 

its structure.  These modifications were implemented based upon 5 years of email, 

support, and training observations regarding areas of past versions of Metrics I/CV 

that were confusing.  The new version of Metrics I/CV makes a significant attempt to 

simplify the process of performing measurements.  Duplicate features, difficulty of 

using a probe station for automation, and integration were addressed.  The resulting 

product, Metrics Technology believes, is much easier to use. 

 

Metrics I/CV version 3.9 also provide a suite of tests including open source 

VBScript algorithms which can be used as-is or modified for the customers 

particular purpose. A fully integrated VBScript Development Environment as well as 

multiple function libraries makes developing sophisticated custom test methods 

available to the administrator but password security provide the right level of control 

for the system’s users. 
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Changes to Metrics I/CV 

 

The following discussion of the changes to Metrics I/CV includes information as to 

why the changes were made.  In addition, replacement functions or procedures are 

listed. 

 

 

New Instrument Support 

Metrics I/CV has added support for several new pieces of test and measurement 

hardware.  These include: 

Instruments 

 QualiTau DSPT9012 (Desktop Semiconductor Parametric Tester) 

 Agilent E4980A (Precision LCR Meter) 

 Agilent B1500A (Semiconductor Device Analyzer) 

 Agilent 8110/81110 (Pulse Generator) 

 Keithley 4200 SCS (Semiconductor Characterization System) 

Thermal Controllers 

 TMMCO Controllers via pcTC 

 Cascade controllers via Nucleus Thermal 

 Suss controllers via ProberBench  

Probe Stations 

All probe stations are supported via GPIB ONLY.  The new VBScript drivers 

require purchase of the Metrics I/CV 3.9 Annual License product. 

 VBScript source code to allow for user modifications 

 Use VBScript source templates to create your own Probe or Thermal 

Drivers for non-supported equipment. 

 Nucleus Vision support 

 Suss Vision support 
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Integrated VBScript Development  

The Metrics I/CV VBScript Algorithm support has undergone major enhancements.  

There is now a Integrated Development Environment with libraries of control for IV 

instruments.  In addition a published interface is provided for the creation of new 

customer-designed probe and thermal drivers.  

The new VBScript Development Kit requires purchase of the Metrics I/CV 3.9 

“Annual License” product which provides a full year of technical support for 

customers developing their own test algorithms. 

 New Integrated Development Environment 

 New Instrument Control Library 

 Source code for advanced test methods including CV, WLR and 

Non-Volatile Memory characterization. 

Complex tests can be developed in the Integrated VBScript editor which provides a 

full-featured script editor with syntax assistance, an interactive test execution 

environment, and comprehensive debugger.  

Metrics Technology provides high-level libraries which include functions for the 

low-level GPIB access to instrument-specific command strings, math functions 

which are available for performing most parameter extraction tasks and additional 

decision branch support. 

 

New Libraries: 

 Control for parameter analyzers 

 Switching control 

 Thermal Control 

 Probing Control 

 

New Test Algorithms 

The Metrics I/CV Annual license includes test algorithms for Wafer Level 

Reliability, Non-Volatile Memory, and general test algorithms.  In addition libraries 

that support the 8110/81110 are provided. (Not included with the Perpetual License)  
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Upgrading from Metrics I/CV 

version 3.0, 3.8 

The process to upgrade Metrics I/CV requires that you backup the previous version, 

and then install version 3.9 on top of version 3.0.  To do this, please perform the 

following steps: 

 

Step 1: Backup the Previous Metrics I/CV 

  

The Metrics I/CV setup program requires that you backup and uninstall the previous 

version.  To do this, please perform the following steps: 

 

DO NOT BACKUP YOUR SOFTWARE INTO THE METRICS DIRECTORY!  

BACKUP TO A DIFFERENT LOCATION. 

 

1. Go to the Tools Menu and select Backup 

2. Allow the backup utility to save a backup on another drive. 
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Step 2: Installing Metrics I/CV Software 

  

The installation program for the Metrics I/CV software installs all components 

necessary to run Metrics I/CV. During the installation you will be prompted to 

furnish a codeword for the various components of the software.  If you install the 

software without the codeword, you will be able to run the software for 7 days, but 

will have to manually enter the codeword in both I/CV and ICS. 

 

Obtain a Codeword 

This codeword is obtained by registering your software with Metrics 

Technology.  Please submit the provided registration form via fax or visit 

our website at www.metricstech.com to register your software and obtain the 

codeword. 

 

The software will run for 7 days without the codeword 

 

 

Procedure to Install I/CV (Upgrade Only) 

1. Insert the Metrics Applications CD into the CD-ROM drive of your 

computer.  

 

2. The CD-ROM will automatically start the installation program.  

 

3. Choose "Install Products" » "Install I/CV".  

 

4. Click Next button on the "Welcome" panel.  

 

http://www.metricstech.com/
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5. Read the "Software License Agreement" and click the Yes button to 

agree to the terms.  

 

6. Complete the User Information fields. The Codeword is found on the 

"Metrics Software Codeword Certificate" for I/CV. Click the Next 

button.  

 

7. Choose "destination location" for installation and click the Next 

button.  

 

8. Select "Typical" setup type and click the Next button.  

 

9. After the installation is finished, re-start the computer.  

 

10. Connect the Security plug to the USB port of your computer.  Note: 

It is recommended the security plug be connected directly to the 

computer.   
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Upgrading from Metrics I/CV 

version 2.1 and Older 

The process to upgrade Metrics I/CV requires that you backup and uninstall the 

previous version, install and configure the new version, import switch settings 

(requires I/CV 3.8 intermediate conversion) or creation of new .DCI formatted 

ASCII file in I/CV 3.9, convert tests to Algorithms, and modify existing scripts.  To 

do this, please perform the following steps: 

 

Step 1: Backup the Previous Metrics I/CV 

  

The Metrics I/CV setup program requires that you backup and uninstall the previous 

version.  To do this, please perform the following steps: 

 

DO NOT BACKUP YOUR SOFTWARE INTO THE METRICS DIRECTORY!  

BACKUP TO A DIFFERENT LOCATION. 

 

3. Install the latest Hot Fix for I/CV version 2.1 (at least Hot Fix 26). 

4. Please backup your ICS database (\Metrics\ics\data). 

5. Backup Module scripts (.scr). 

6. Backup Die scripts (.die). 

7. Backup Wafer Plans (.map) 

8. Backup Module stepping lists (.mod) 

9. Backup Probe Lists (.plist) 

10. Backup Data files (.dat)   

11. Open the Metrics Switch program and select Export.  Enter a file 

name and location, then click OK.  Then highlight the desired switch 

pattern names to be exported (Hold the CTRL key and select using 

the mouse).  Select the Export as ASCII option and click the Export 

button. This file can be converted using I/CV 3.8 or used to create a 

.DCI formatted file for import into I/CV 3.9 (see Device Connections 

manual for details). 

12. Run the Uninstall Programs from the Control Panel of Microsoft 

Windows.  Delete all programs with Metrics in their name.  Click yes 

to uninstall common components. 

13. Delete the Metrics directory. 
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Step 2: Installing Metrics I/CV Software 

  

The installation program for the Metrics I/CV software installs all components 

necessary to run Metrics I/CV. During the installation you will be prompted to 

furnish a codeword for the various components of the software.  If you install the 

software without the codeword, you will be able to run the software for 7 days, but 

will have to manually enter the codeword in both I/CV and ICS. 

 

Obtain a Codeword 

This codeword is obtained by registering your software with Metrics 

Technology.  Please submit the provided registration form via fax or visit 

our website at www.metricstech.com to register your software and obtain the 

codeword. 

 

The software will run for 7 days without the codeword 

 

 

Procedure to Install I/CV (Upgrade Only) 

11. Insert the Metrics Applications CD into the CD-ROM drive of your 

computer.  

 

12. The CD-ROM will automatically start the installation program.  

 

13. Choose "Install Products" » "Install I/CV".  

 

14. Click Next button on the "Welcome" panel.  

 

http://www.metricstech.com/
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15. Read the "Software License Agreement" and click the Yes button to 

agree to the terms.  

 

16. Complete the User Information fields. The Codeword is found on the 

"Metrics Software Codeword Certificate" for I/CV. Click the Next 

button.  

 

17. Choose "destination location" for installation and click the Next 

button.  

 

18. Select "Typical" setup type and click the Next button.  

 

19. After the installation is finished, re-start the computer.  

 

20. Connect the Security plug to the USB port of your computer.  Note: 

It is recommended the security plug be connected directly to the 

computer.   
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Step 3: Configuring I/CV 

 

Probe Station Configuration 

After installing Metrics I/CV, it must be configured.  The first time I/CV is 

started, it will automatically run the Configuration Wizard Utility. This 

utility will ask the operator a series of questions to determine the correct 

configuration for the probe station drivers of the Metrics I/CV software. 

  

Using the Configuration Wizard Utility 

 The Configuration Wizard presents a series of questions to the user. The 

user-supplied responses allow the software to automatically configure. The 

Configuration Wizard can be re-run at any time to change the setup.  To 

manually start the Configuration Wizard, follow these steps: 

1. Start the Metrics I/CV Software. 

2. Open the System Configuration window by selecting Tools » System 

Configuration.  

3. Click on the Configuration Wizard button found on the "About 

Information" Tab.  
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4. Click the "OK" button.  

 

5. Select the Probe Station you are using.  

6. Provide the GPIB address of the station.  
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Instrument Configuration 

The Configuration Wizard Utility will setup the probe station information, 

however typically other components must also be setup in order to run the 

testing.  These components are setup manually by the user the first time the 

system is run.  These configurations are then saved and automatically loaded 

each time the software is started. 

 

 Instrument Library 

The Metrics I/CV Instrument Library contains setup information for the 

instruments used by: 

 The Device Connection Control (Switch Matrix). 

 Instruments used by the Metrics I/CV supplied algorithms.   

 Probe Station Control. 
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Switch Matrix Configuration 

Version 3.9 of Metrics I/CV has completely integrated the Switch Matrix 

Control within I/CV.  Therefore the configuration of a switch matrix is now 

provided within the Metrics I/CV System Configuration.   

 

 

To configure a switch matrix: 

1. Start the Metrics I/CV Software. 

2. Open the System Configuration window by selecting Tools » System 

Configuration.  

3. Click the Instrument Library tab to display a list of configured 

instruments. 

4. Click the Add button to open the Instrument Definition window.  

Enter the following: 

a. Name- A unique name that identifies the 

instrument. 
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b. Description (optional)- Additional description of 

the instrument. 

c. Group- Select “Switch” from the pull-down list. 

d. Driver- Select the driver for your instrument from 

the list. 

e. Physical Interface- Select the GPIB device you 

will connect to the switch matrix through. 

5. Primary Address- Enter the GPIB address of the switch matrix. 

6. Click the Next button to open the Instrument Configuration window.  

Confirm the instrument is connected to the GPIB bus and click the 

Poll Configuration button. 

7. Click the Finish button to complete the addition of the switch matrix. 
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Instrument (SPA, CMU) Configuration 

Metrics I/CV Version 3.9 includes a collection of pre-written test algorithms.  

These algorithms control selected CV and IV instruments.  These 

instruments must be configured in this section. 

Note: If you are using the ICS Tool you will need to configure the 

instrument in that Tool as well. 

 

To configure an Instrument: 

1. Start the Metrics I/CV Software. 

2. Open the System Configuration window by selecting Tools » System 

Configuration.  

3. Click the Instrument Library tab to display a list of configured 

instruments. 

4. Click the Add button to open the Instrument Definition window.  

Enter the following: 
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a. Name- A unique name that identifies the 

instrument.  If you will be using the I/CV 

algorithms provided by Metrics Technology, you 

MUST name the parameter analyzer “SPA1” and 

the Capacitance Meter “CMU1”. 

b. Description (optional)- Additional description of 

the instrument. 

c. Group- Select “Instrument” from the pull-down 

list. 

d. Driver- Select the driver for your instrument from 

the list. 

e. Physical Interface- Select the GPIB device you 

will connect to the switch matrix through. 

5. Primary Address- Enter the GPIB address of the instrument. 

6. Click the Next button to open the Instrument Configuration window.  

Confirm the instrument is connected to the GPIB bus and click the 

Poll Configuration button. 

7. Click the Finish button to complete the addition of the instrument. 
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Step 4: Import Switch Patterns 

After the Switch is configured is the System Configuration, you can import the 

patterns to the new Device Connections Editor.  The import of the patterns requires 

that the switch be configured exactly the same. The import conversion for I/CV 3.8 

works from the file directly.  AFTER IMPORTING THE SWITCH PATTERNS 

THEY MUST BE TESTED TO CONFIRM THEY WORK PROPERLY.   

 

To import the switch file 

1. Make sure the latest HotFix of Metrics I/CV version 3.9 is installed 

(at least version HF09). 

2. Start Metrics I/CV and then select Development >> Device 

Connections Editor. 

3. Click the Import button and select the file that you exported. 

4. The patterns will be imported. 

 

Note: The switch must be configured prior to importing. 

Bulk import of switch device connections is covered in the in line manual for the 

Device Connections Editor. See the Help page for more details. After the .DCI 

ASCII formatted file is created you can import the patterns to the new Device 

Connections Editor.  The import of the patterns requires that the switch be 

configured exactly the same as defined in the .DCI file.  
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Step 5: Convert Tests to Algorithms 

In version 2.1 VBScript and ICS tests were treated as separate types of tests.  The 

tests are generated using different tools, but the result is the same, an Algorithm to 

perform a measurement.  Beginning with I/CV version 3.9 all such tests are referred 

to as Algorithms, regardless of the tool (ICS or VBScript) used to generate them.  As 

result, the Algorithms are saved using the windows file system.  The location of 

Algorithms is within the Metrics\algs directory.  Note that sub-directories may be 

used for organizing the groups of Algorithms. 

 

The first step for creating an Algorithm from an ICS version 3.6.0 or older test is to 

use ICS version 3.7.0 to save it in the windows file system. 

 

To Convert an ICS Test to an Algorithm 

1. From your backup created in Step 1: Backup the Previous Metrics 

I/CV, find the ICS database.  By default the ICS database was in the 

Metrics\ICS directory.  It was a folder named Data and contained 

many sub-folders. 

2. Copy this folder (with all sub-folders) to the Metrics\ICS directory 

on the new installation of I/CV. 

3. Start I/CV and select Development -> Algorithm Editors -> ICS. 

4. Once ICS starts, select File -> Legacy Database -> Open.  You will 

see the contents of the ICS database.  Select the database file to be 

converted using its Attributes and click OK. 

5. After the file opens, select File -> Save As.   

6. Navigate to the Metrics\algs directory.  Provide a name for the file.  

Either save the file in this directory or create a New Folder within 

this directory and save the file. 

7. Repeat steps 4-6 for the other tests you wish to convert. 

 

Note: It may seem like a lot of entries from the ICS database may need to be 

converted.  However, the ICS database contains a combination of Both the Test 

Method and Data generated.  You only need the Test Method for use with I/CV.  

This will result in the number of old ICS tests to be converted to actually be very 

small relative to the number of data files that are contained in the old ICS database.  
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To Convert a VBScript Test to an Algorithm 

1. From your backup created in Step 1: Backup the Previous Metrics 

I/CV, find the VBScript algorithm. 

2. Copy the algorithm to the Metrics\algs directory.  Either copy the file 

in this directory or create a New Folder within this directory and coy 

the file to that directory.    



Software Migration Guide  24  

Step 6: Modify Test Scripts 

In version 2.1 Module and Die Scripts included some functions that have been 

replaced.  The changed functions and their replacements are listed in the section 

preceding this one.  To run in a true I/CV 3.9 mode all of these functions must be 

replaced.  An additional Mode has been created called Legacy Mode which allows 

the use of many of the replaced functions.  More information about Legacy Mode 

can be found in the next section of this document. 

 

 

To Convert an Obsolete Function 

1. From I/CV open a Module Test by selecting Development -> Module 

Test Editor and selecting the Module Script of interest. 

2. Click the obsolete line in the script. 

3. Click Delete and confirm that you wish to delete the line. 

4. Click Insert. 

5. Select the replacement function   

6. Configure the replacement function that you wish to use. 

7. Save the script when all functions are converted. 
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Using Legacy Mode to Run I/CV version 

2.1 Scripts 

Several functions from I/CV version 2.1 have been moved for the purpose of 

improving the software, providing operator safety, or improving the stability of the 

software.  The result is that some I/CV version 2.1 scripts will require modification 

to run in I/CV version 3.9.  As an intermediate step to completely porting scripts to 

working in I/CV, the user may opt to enable the Legacy Mode.  This will allow I/CV 

version 2.1 scripts to run in I/CV version 3.9 with a minimum number of 

modifications.  If you were previously using Compatibility Mode, please 

deactivate it as it will expire on October 31, 2005.  If Compatibility Mode is not 

disabled, the software will continue to run but display messages about the 

expired Compatibility Mode. 
 

The following functions must still be ported to use I/CV version 2.1 scripts: 

 Switching Control- Change to the Device Connections Editor. 

 Run ICS Test and Run ICS Sequence are replaced by Execute 

Algorithm. 

 Inputs to ICS Tests accessed by the Execute Algorithm function will 

continue to be available, the values are limited to +/- 20V and +/- 100 

mA.  If a value is passed to the test that exceeds this level, the default 

value for the test will be used instead.  For tests that require larger 

values to be received as Inputs, the ICS algorithm must be called by a 

VBScript algorithm (please see the VBScript documentation for 

instructions on how to do this).  

 Run LabView- Delete, this function is no longer supported. 

 Run VEE- This function is supported in a limited manner.  Note that 

VEE has a memory leak in it and if you try to run a large number of 

VEE tests across the wafer it will eventually crash the PC.  This is a 

known defect in VEE and the user acknowledges this when using the 

function and when accepting the software license.  Due to this defect 

Metrics Technology does not provide any support for this function or 

guarantee it will work. 

 

To activate Legacy Mode, select Tools -> System Config.  Click the Configuration 

Manager tab and highlight the Legacyy Mode entry.  Change the Value to ON and 

click the Set button. 

 

  

 


